Description
While HIT ACM Group finished their contest in Shanghai and is heading back Harbin, their train was delayed due to the heavy snow. Their mobile phones are all running out of battery very quick. Luckily, zb has a super mobile charger that can charge all phones.
There are N people on the train, and the i-th phone has p[i] percentage of power, the super mobile charger can charge at most M percentage of power.
Now zb wants to know, at most how many phones can be charged to full power. (100 percent means full power.)
Input
The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).
For each test case, the first line contains two integers N, M(1 <= N <= 100,0 <= M <= 10000) , the second line contains N integers p[i](0 <= p[i] <= 100) meaning the percentage of power of the i-th phone.
Output
For each test case, output the answer of the question.
Sample Input
2
3 10
100 99 90
3 1000
0 0 0
Sample Output
2
3
理解:
你有一個(gè)移動(dòng)電源英上,現(xiàn)在看你最多能給多少人的手機(jī)充滿電趴酣。
簡(jiǎn)單排序就好舆声。
代碼部分
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int t,n,m,a[101],sum,all;
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
cin>>t;
while(t--){
sum=0;
memset(a,0,sizeof(a));
cin>>n>>m;
all=m;
for(int i=0;i<n;i++)
cin>>a[i];
sort(a,a+n,cmp);
for(int i=0;i<n;i++){
if(a[i]==100)
{sum++;continue;}
if(a[i]<100){
if(all>=(100-a[i])){
all-=(100-a[i]);
a[i]=100;
sum++;
continue;
}
if(all<(100-a[i])){
break;
}
}
}
cout<<sum<<endl;
}
return 0;
}