題目
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) – the number of cities (and the cities are numbered from 0 to N-1), M – the number of roads, C1 and C2 – the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.
Output
For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
分析題目
題目要求的是最短路徑,以及點(diǎn)權(quán)值的加權(quán)丁溅,用Dijkstra算法
學(xué)習(xí)Dijkstra算法
此處參考了從杰的透徹理解地杰斯特算法
如圖1探遵,
步驟 | 集合S | 集合U |
---|---|---|
1 | 選入A S={A(0)} 以A為中間點(diǎn)開始找 |
U = {B(6), C(3), D(∞), E(∞), F(∞) |
2 | 選入C S = {A(0), C(3)} 以A->C開始找涯穷,若為最短路徑則更新U |
U = {B(5), D(6), E(7), F(∞)} |
3 | 選入B S = {A(0), C(3), B(5)} 以A-B開始找藏雏,若為最短路徑則更新U |
U = {D(6), E(7), F(∞)} |
4 | S = {A(0), C(3), B(5), D(6)} | U = {E(7), F(9)} |
5 | S = {A(0), C(3), B(5), D(6), E(7)} | U = F(9) |
6 | S = {A(0), C(3), B(5), D(6), E(7), F(9)} | U 集合為空 |
按最短路徑長(zhǎng)度的遞增次序依次把第二組的頂點(diǎn)加入S中。在加入的過程中掘殴,總保持從源點(diǎn)v到S中各頂點(diǎn)的最短路徑長(zhǎng)度不大于從源點(diǎn)v到U中任何頂點(diǎn)的最短路徑長(zhǎng)度
代碼
#include <iostream>
#include <algorithm>
using namespace std;
int n, m, c1, c2;
int e[510][510], weight[510], dis[510], num[510], w[510];
bool visit[510];
const int inf = 99999999;
int main() {
scanf("%d%d%d%d", &n, &m, &c1, &c2);
for(int i = 0; i < n; i++)
scanf("%d", &weight[i]);
fill(e[0], e[0] + 510 * 510, inf);
fill(dis, dis + 510, inf);
int a, b, c;
for(int i = 0; i < m; i++) {
scanf("%d%d%d", &a, &b, &c);
e[a][b] = e[b][a] = c;
}
dis[c1] = 0;
w[c1] = weight[c1];
num[c1] = 1;
for(int i = 0; i < n; i++) {
int u = -1, minn = inf;
for(int j = 0; j < n; j++) {
if(visit[j] == false && dis[j] < minn) {
u = j;
minn = dis[j];
}
}
if(u == -1) break;
visit[u] = true;
for(int v = 0; v < n; v++) {
if(visit[v] == false && e[u][v] != inf) {
if(dis[u] + e[u][v] < dis[v]) {
dis[v] = dis[u] + e[u][v];
num[v] = num[u];
w[v] = w[u] + weight[v];
} else if(dis[u] + e[u][v] == dis[v]) {
num[v] = num[v] + num[u];
if(w[u] + weight[v] > w[v])
w[v] = w[u] + weight[v];
}
}
}
}
printf("%d %d", num[c2], w[c2]);
return 0;
}
參考代碼:日吹柳神
總結(jié)
- 使用fill的時(shí)候起意,注意是fill一維矩陣還是二維矩陣
int dis[500];
int E[500][500];
fill(dis,dis+500,inf); //對(duì)一維矩陣
fill(E[0],E[0]+500*500,inf);//對(duì)二維矩陣
- 注意fill和memset區(qū)別
其中fill能用的范圍更廣服爷,而memset一般用于初始化char數(shù)組获诈、string心褐,如果用于初始化int數(shù)組的話只能填入0或1
具體用法:fill和memset區(qū)別