Genealogical tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5027 Accepted: 3317 Special Judge
Description
The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.
Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.
Output
The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.
Sample Input
5
0
4 5 1 0
1 0
5 3 0
3 0
Sample Output
2 4 5 3 1
Source
Ural State University Internal Contest October'2000 Junior Session
題意:
有n個節(jié)點僚碎,形成父子關(guān)系,求一個從老到小的合理的順序君仆。
思路:
拓撲排序伶唯×梗可得n個節(jié)點形成一個有向無環(huán)圖,每次取出其中一個入度為0的節(jié)點(無其他節(jié)點指向其)绪励,最終得到的順序既是題目所求铐炫。
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 100;
int buf[maxn + 5][maxn + 5];
int cnt[maxn + 5];
int ans[maxn + 5];
int main() {
int n;
while (scanf("%d", &n) != EOF) {
memset(buf, 0, sizeof(buf));
memset(cnt, 0, sizeof(cnt));
int num;
for (int i = 1; i <= n; ++i) {
while (scanf("%d", &num) && num) {
buf[i][num] = 1;
++cnt[num];
}
}
int top = 0;
for (int i = 1; i <= n; ++i) {
for (int j = 1; j <= n; ++j) {
if (cnt[j] == 0) {
ans[top++] = j;
cnt[j] = -1;
for (int k = 1; k <= n; ++k) {
if (buf[j][k] == 1)
--cnt[k];
}
break;
}
}
}
for (int i = 0; i < top - 1; ++i)
printf("%d ", ans[i]);
printf("%d\n", ans[top - 1]);
}
return 0;
}