1119.Pre- and Post-order Traversals

題目描述

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

考點(diǎn)

1.樹的三種遍歷方式鞋诗;
2.前序后序轉(zhuǎn)中序轻庆。

思路

1.根據(jù)特點(diǎn)求解
前序的輸出順序?yàn)?code>根左右朽基,后序?yàn)?code>左右根,因此只要前序的子序列的第一個(gè)值等于后序子序列的最后一個(gè)值霎匈,這個(gè)值就是根結(jié)點(diǎn)的值∷桶郑可以通過這個(gè)特點(diǎn)遞歸建樹铛嘱。
2.中序遍歷
3.如何確定是否唯一?
不唯一的情況就是某棵子樹的根結(jié)點(diǎn)只有一個(gè)孩子結(jié)點(diǎn)袭厂,那么這個(gè)孩子結(jié)點(diǎn)可以是左孩子墨吓,也可以是右孩子。反之纹磺,如果某棵子樹有左右孩子結(jié)點(diǎn)那么它一定是唯一可確定的帖烘,即最終前序和后序兩個(gè)數(shù)組一定可以被分割成[a, b][a, b]的形式,即prel=prerpostl=postr橄杨。如果prel>prer秘症,那么不可唯一確定。

代碼

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<int> pre, post;
queue<int> in;
int tree[30][2], root, isuniq=1;
void inorder(int &index, int prel,int prer, int postl, int postr) {
    if (prel > prer) {
        isuniq = 0;return;
    }
    index = prel;
    if (prel == prer) return;
    int e = postr;
    while (pre[prel + 1] != post[e]) e--;
    inorder(tree[index][0], prel + 1, prel + e - postl + 1, postl, e);
    inorder(tree[index][1], prel + e - postl + 2, prer, e + 1, postr-1);
}
void inorder(int r) {
    if (tree[r][0] != 0) inorder(tree[r][0]);
    in.push(pre[r]);
    if (tree[r][1] != 0) inorder(tree[r][1]);
}
int main() {
    int n, i, t;
    cin >> n;
    pre.resize(n); post.resize(n);
    for (i = 0; i < n; i++) cin >> pre[i];
    for (i = 0; i < n; i++) cin >> post[i];
    inorder(root, 0, n - 1, 0, n - 1);
    cout << (isuniq == 1 ? "Yes" : "No") << endl;
    inorder(0);
    while (!in.empty()) {
        cout << in.front() << (in.size() == 1 ? "\n" : " ");
        in.pop();
    }
    return 0;
}
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請(qǐng)聯(lián)系作者
  • 序言:七十年代末式矫,一起剝皮案震驚了整個(gè)濱河市乡摹,隨后出現(xiàn)的幾起案子,更是在濱河造成了極大的恐慌采转,老刑警劉巖聪廉,帶你破解...
    沈念sama閱讀 211,194評(píng)論 6 490
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件,死亡現(xiàn)場(chǎng)離奇詭異故慈,居然都是意外死亡板熊,警方通過查閱死者的電腦和手機(jī),發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 90,058評(píng)論 2 385
  • 文/潘曉璐 我一進(jìn)店門惯悠,熙熙樓的掌柜王于貴愁眉苦臉地迎上來邻邮,“玉大人,你說我怎么就攤上這事克婶⊥惭希” “怎么了丹泉?”我有些...
    開封第一講書人閱讀 156,780評(píng)論 0 346
  • 文/不壞的土叔 我叫張陵,是天一觀的道長(zhǎng)鸭蛙。 經(jīng)常有香客問我摹恨,道長(zhǎng),這世上最難降的妖魔是什么娶视? 我笑而不...
    開封第一講書人閱讀 56,388評(píng)論 1 283
  • 正文 為了忘掉前任晒哄,我火速辦了婚禮,結(jié)果婚禮上肪获,老公的妹妹穿的比我還像新娘寝凌。我一直安慰自己,他們只是感情好孝赫,可當(dāng)我...
    茶點(diǎn)故事閱讀 65,430評(píng)論 5 384
  • 文/花漫 我一把揭開白布较木。 她就那樣靜靜地躺著,像睡著了一般青柄。 火紅的嫁衣襯著肌膚如雪伐债。 梳的紋絲不亂的頭發(fā)上,一...
    開封第一講書人閱讀 49,764評(píng)論 1 290
  • 那天致开,我揣著相機(jī)與錄音峰锁,去河邊找鬼。 笑死双戳,一個(gè)胖子當(dāng)著我的面吹牛虹蒋,可吹牛的內(nèi)容都是我干的。 我是一名探鬼主播拣技,決...
    沈念sama閱讀 38,907評(píng)論 3 406
  • 文/蒼蘭香墨 我猛地睜開眼千诬,長(zhǎng)吁一口氣:“原來是場(chǎng)噩夢(mèng)啊……” “哼!你這毒婦竟也來了膏斤?” 一聲冷哼從身側(cè)響起徐绑,我...
    開封第一講書人閱讀 37,679評(píng)論 0 266
  • 序言:老撾萬(wàn)榮一對(duì)情侶失蹤,失蹤者是張志新(化名)和其女友劉穎莫辨,沒想到半個(gè)月后傲茄,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體,經(jīng)...
    沈念sama閱讀 44,122評(píng)論 1 303
  • 正文 獨(dú)居荒郊野嶺守林人離奇死亡沮榜,尸身上長(zhǎng)有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點(diǎn)故事閱讀 36,459評(píng)論 2 325
  • 正文 我和宋清朗相戀三年盘榨,在試婚紗的時(shí)候發(fā)現(xiàn)自己被綠了。 大學(xué)時(shí)的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片蟆融。...
    茶點(diǎn)故事閱讀 38,605評(píng)論 1 340
  • 序言:一個(gè)原本活蹦亂跳的男人離奇死亡草巡,死狀恐怖,靈堂內(nèi)的尸體忽然破棺而出型酥,到底是詐尸還是另有隱情山憨,我是刑警寧澤查乒,帶...
    沈念sama閱讀 34,270評(píng)論 4 329
  • 正文 年R本政府宣布,位于F島的核電站郁竟,受9級(jí)特大地震影響玛迄,放射性物質(zhì)發(fā)生泄漏。R本人自食惡果不足惜棚亩,卻給世界環(huán)境...
    茶點(diǎn)故事閱讀 39,867評(píng)論 3 312
  • 文/蒙蒙 一蓖议、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧讥蟆,春花似錦勒虾、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 30,734評(píng)論 0 21
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽(yáng)。三九已至钧栖,卻和暖如春,著一層夾襖步出監(jiān)牢的瞬間婆翔,已是汗流浹背拯杠。 一陣腳步聲響...
    開封第一講書人閱讀 31,961評(píng)論 1 265
  • 我被黑心中介騙來泰國(guó)打工, 沒想到剛下飛機(jī)就差點(diǎn)兒被人妖公主榨干…… 1. 我叫王不留啃奴,地道東北人潭陪。 一個(gè)月前我還...
    沈念sama閱讀 46,297評(píng)論 2 360
  • 正文 我出身青樓,卻偏偏與公主長(zhǎng)得像最蕾,于是被迫代替她去往敵國(guó)和親依溯。 傳聞我的和親對(duì)象是個(gè)殘疾皇子,可洞房花燭夜當(dāng)晚...
    茶點(diǎn)故事閱讀 43,472評(píng)論 2 348

推薦閱讀更多精彩內(nèi)容