我的PAT系列文章更新重心已移至Github磷醋,歡迎來看PAT題解的小伙伴請到Github Pages瀏覽最新內(nèi)容(本篇文章鏈接)宗侦。此處文章目前已更新至與Github Pages同步。歡迎star我的repo德崭。
題目
Programming Ability Test (PAT) is organized by the College of Computer Science
and Technology of Zhejiang University. Each test is supposed to run
simultaneously in several places, and the ranklists will be merged immediately
after the test. Now it is your job to write a program to correctly merge all
the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains
a positive number (
), the number of test locations. Then
ranklists follow, each starts with a line containing a positive integer (
), the number of testees, and then
lines containing the
registration number (a 13-digit number) and the total score of each testee.
All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then
print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to . The output must be sorted in
nondecreasing order of the final ranks. The testees with the same score must
have the same rank, and the output must be sorted in nondecreasing order of
their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
思路
一道有關于排序的題目缘厢。題目要求得到每個考生分排名和總排名台谍,因此關鍵點就在于如何
排序镐依。
思路:由于讀取是以考點為組匹涮,因此可以在每讀完一個考點,即對此考點內(nèi)的考生進
行排序槐壳,得到分排名然低。最后再對整個列表進行排序,得到總排名务唐。
實現(xiàn):
使用一個數(shù)組存儲雳攘。排序時,使用qsort
傳入不同位置和長度參數(shù)即可绍哎。
代碼
最新代碼@github来农,歡迎交流
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
/* registration number, location nubmer, total score, final rank, local rank */
typedef struct {
char reg[14];
int loc, score, rank, lrank;
} Testee, *pTestee;
int cmp(const void *a, const void *b)
{
pTestee p1 = *(pTestee*)a, p2 = *(pTestee*)b;
if(p1->score != p2->score)
return p2->score - p1->score;
else
return strcmp(p1->reg, p2->reg);
}
int main()
{
int N, K;
Testee buffers[100 * 300] = {0}, *q = buffers;
pTestee testees[100 * 300] = {0}, *p = testees;
scanf("%d", &N);
for(int n = 0; n < N; n++)
{
/* read one test location */
scanf("%d", &K);
for(int k = 0; k < K; k++, p++)
{
*p = q++; /* use a new cell */
(*p)->loc = n + 1;
scanf("%s %d", (*p)->reg, &(*p)->score);
}
/* sort the kth location sublist */
qsort(p - K, K, sizeof(pTestee), cmp);
/* get the local rank, i is the offset (we need left K cells of p) */
int lrank = 1;
pTestee *lp;
(*(p - K))->lrank = lrank; /* boundary special case */
for(int i = 1; i < K; i++)
{
lp = p - K + i;
if((*lp)->score != (*(lp - 1))->score)
lrank = i + 1;
(*lp)->lrank = lrank;
}
}
/* sort the whole list */
qsort(testees, p - testees, sizeof(pTestee), cmp);
/* get the final rank */
int rank = 1;
pTestee *fp;
(*testees)->rank = rank;
for(int i = 1; testees + i < p; i++)
{
fp = testees + i;
if((*fp)->score != (*(fp - 1))->score)
rank = i + 1;
(*fp)->rank = rank;
}
/* output */
printf("%ld\n", p - testees);
for(pTestee* i = testees; i < p; i++)
printf("%s %d %d %d\n", (*i)->reg, (*i)->rank, (*i)->loc, (*i)->lrank);
return 0;
}