Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. Note: the number of first circle should always be 1.
Input
n (0 < n < 20).
output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. You are to write a program that completes above process. Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
理解:
學(xué)了深搜那么久……在比賽的時(shí)候碰到這個(gè)題還是一籌莫展。
賽后才慢慢有了方法。用DFS 回溯杖刷。
代碼部分
#include <cstdio>
using namespace std;
int n,a[21],b[21],t;
int pri(int x){
for(int i=2;i*i<=x;i++){
if(x%i==0)
return 0;
}
return 1;
}
void dfs(int num){
if(n==num&&pri(a[n-1]+1)){
for(int i=0;i<n;i++)
printf(i!=n-1?"%d ":"%d\n",a[i]);
}
else{
for(int i=2;i<=n;i++)
if(!b[i]&&pri(i+a[num-1])){
a[num]=i;
b[i]=1;
dfs(num+1);
b[i]=0;//這里非常關(guān)鍵,搜完這個(gè)數(shù)下的情況飞盆,要把這個(gè)數(shù)恢復(fù)成未使用的狀態(tài)才能進(jìn)行下次的搜索
}
}
}
int main(){
t=1;
while(scanf("%d",&n)!=EOF){
a[0]=1;
for(int i=0;i<n;i++)
b[i]=0;
printf("Case %d:\n",t++);
dfs(1);
puts("");
}
}