題目鏈接:圓桌問題
題目:
圓桌上圍坐著2n個人凉馆。其中n個人是好人棺妓,另外n個人是壞人瞬场。如果從第一個人開始數(shù)數(shù),數(shù)到第m個人涧郊,則立即處死該人;然后從被處死的人之后開始數(shù)數(shù)眼五,再將數(shù)到的第m個人處死……依此方法不斷處死圍坐在圓桌上的人妆艘。試問預(yù)先應(yīng)如何安排這些好人與壞人的座位,能使得在處死n個人之后看幼,圓桌上圍坐的剩余的n個人全是好人批旺。
Input
多組數(shù)據(jù),每組數(shù)據(jù)輸入:好人和壞人的人數(shù)n(<=32767)诵姜、步長m(<=32767)汽煮;
Output
對于每一組數(shù)據(jù),輸出2n個大寫字母棚唆,‘G’表示好人暇赤,‘B’表示壞人,50個字母為一行宵凌,不允許出現(xiàn)空白字符鞋囊。相鄰數(shù)據(jù)間留有一空行。
Sample Input 1
2 3
Sample Input 2
2 4
Sample Output 1
GBBG
Sample Output 2
BGGB
思路:以前用的循環(huán)來判斷位置瞎惫,因為每次都有人要離開溜腐,直接用取模是不可行的,這次用vector模擬圓環(huán)瓜喇,走一個刪一個挺益,但是要注意取 模邊界和刪除走的人為最后一個時下一個人的坐標(biāo)的改變
代碼:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
char vis[66666];
vectorp;
int n,m,N;
int pos;
int flag=0;
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
p.clear();
memset(vis,'G',sizeof(vis));
N=2*n;
pos=1;
for(int i=1;i<=N;i++)
p.push_back(i);
while(N>n)
{
pos=pos+m-1;
if(pos>N)
{
pos%=N;
if(pos==0)
pos=N;
}
vis[p[pos-1]]='B';
p.erase(p.begin()+pos-1);
if(pos==N)
pos=1;
N--;
}
N=2*n;
for(int i=1;i<=N;i++)
{
printf("%c",vis[i]);
if(i%50==0)
printf("\n");
}
printf("\n\n");
}
return 0;
}