PAT 甲級(jí) 刷題日記|A 1090 Highest Price in Supply Chain (25 分)

單詞積累

increment 增量 增加

題目

A supply chain is a network of retailers(零售商), distributors(經(jīng)銷商), and suppliers(供應(yīng)商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence they are numbered from 0 to N?1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. S root for the root supplier is defined to be ?1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6結(jié)尾無空行

Sample Output:

1.85 2結(jié)尾無空行

思路

這是一個(gè)由零售商害驹、經(jīng)銷商與供應(yīng)商構(gòu)成的一般樹。需要找到最大深度蛤育,以及該深度存在的葉節(jié)點(diǎn)數(shù)宛官。

自己一開始對(duì)一般樹的掌握不很好,想到了用類似并查集的方法去做瓦糕,這個(gè)缺點(diǎn)是每次都是從葉節(jié)點(diǎn)處開始查找底洗,如果出現(xiàn)下圖所示的極端情況時(shí),時(shí)間復(fù)雜的是O(n 方)咕娄,最后一個(gè)樣例超時(shí)亥揖。


1628586481263.png

參考的做法是,用向量存儲(chǔ)孩子圣勒,這棵樹就可以表示為數(shù)組向量费变。數(shù)組中的第i個(gè)元素,就是以i為父節(jié)點(diǎn)的所有節(jié)點(diǎn)構(gòu)成的向量圣贸。最大深度只需從根節(jié)點(diǎn)處開始遍歷挚歧。

代碼1

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100001;
int num[maxn];
int father[maxn];
int height[maxn];
int N;
double P, r;

void inital() {
    for (int i = 0; i < N; i++) {
        father[i] = i;
        height[i] = 0;
    }
}

int findfather(int x) {
    int times = 0;
    while (father[x] != -1) {
        x = father[x];
        times++;
    }
    return times;
}

void Union(int a, int b) {
    father[a] = b;
    if (b != -1) height[b] = 1;
}


int main() {
    cin>>N>>P>>r;
    inital();
    for (int i = 0; i < N; i++) {
        scanf("%d", &num[i]);
        Union(i, num[i]);
    }
    int res = 0;
    int clu = 0;
    for (int i = 0; i < N; i++) {
        if(height[i] == 0) {
            if(findfather(i) == res) clu++;
            else if(findfather(i) > res) {
                res = findfather(i);
                clu = 1;
            }
        }
    }
    double price = P * pow(1 + r * 0.01, res);
    printf("%.2f %d", price, clu);
    
} 

代碼2(BFS)

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100001;
vector<int> num[maxn];
int N;
double P, r;
int maxdepth = 0;
int clus = 0;


void BFS(int root, int depth) {
    if (num[root].size() == 0) {
        
        if (depth == maxdepth) {
            clus++;
        } else if (depth > maxdepth) {
            clus = 1;
            maxdepth = depth;
        }
        return;
    }
    
    for (int i = 0; i <num[root].size(); i++) {
        BFS(num[root][i], depth + 1);
    }
}

int main() {
    cin>>N>>P>>r;
    int root = -1;
    int temp;
    for (int i  = 0; i < N; i++) {
        cin>>temp;
        if (temp == -1) root = i;
        else {
            num[temp].push_back(i);
        }
    }
    if (root != -1) BFS(root, 0);
    double price = P * pow(1 + r * 0.01, maxdepth);
    printf("%.2f %d", price, clus);
}
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請(qǐng)聯(lián)系作者
  • 序言:七十年代末,一起剝皮案震驚了整個(gè)濱河市吁峻,隨后出現(xiàn)的幾起案子滑负,更是在濱河造成了極大的恐慌,老刑警劉巖用含,帶你破解...
    沈念sama閱讀 216,372評(píng)論 6 498
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件矮慕,死亡現(xiàn)場離奇詭異,居然都是意外死亡啄骇,警方通過查閱死者的電腦和手機(jī)痴鳄,發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 92,368評(píng)論 3 392
  • 文/潘曉璐 我一進(jìn)店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來肠缔,“玉大人夏跷,你說我怎么就攤上這事∶魑矗” “怎么了槽华?”我有些...
    開封第一講書人閱讀 162,415評(píng)論 0 353
  • 文/不壞的土叔 我叫張陵,是天一觀的道長趟妥。 經(jīng)常有香客問我猫态,道長,這世上最難降的妖魔是什么? 我笑而不...
    開封第一講書人閱讀 58,157評(píng)論 1 292
  • 正文 為了忘掉前任亲雪,我火速辦了婚禮勇凭,結(jié)果婚禮上,老公的妹妹穿的比我還像新娘义辕。我一直安慰自己虾标,他們只是感情好,可當(dāng)我...
    茶點(diǎn)故事閱讀 67,171評(píng)論 6 388
  • 文/花漫 我一把揭開白布灌砖。 她就那樣靜靜地躺著璧函,像睡著了一般。 火紅的嫁衣襯著肌膚如雪基显。 梳的紋絲不亂的頭發(fā)上蘸吓,一...
    開封第一講書人閱讀 51,125評(píng)論 1 297
  • 那天,我揣著相機(jī)與錄音撩幽,去河邊找鬼库继。 笑死,一個(gè)胖子當(dāng)著我的面吹牛窜醉,可吹牛的內(nèi)容都是我干的宪萄。 我是一名探鬼主播,決...
    沈念sama閱讀 40,028評(píng)論 3 417
  • 文/蒼蘭香墨 我猛地睜開眼酱虎,長吁一口氣:“原來是場噩夢啊……” “哼雨膨!你這毒婦竟也來了擂涛?” 一聲冷哼從身側(cè)響起读串,我...
    開封第一講書人閱讀 38,887評(píng)論 0 274
  • 序言:老撾萬榮一對(duì)情侶失蹤,失蹤者是張志新(化名)和其女友劉穎撒妈,沒想到半個(gè)月后恢暖,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體,經(jīng)...
    沈念sama閱讀 45,310評(píng)論 1 310
  • 正文 獨(dú)居荒郊野嶺守林人離奇死亡狰右,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點(diǎn)故事閱讀 37,533評(píng)論 2 332
  • 正文 我和宋清朗相戀三年杰捂,在試婚紗的時(shí)候發(fā)現(xiàn)自己被綠了。 大學(xué)時(shí)的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片棋蚌。...
    茶點(diǎn)故事閱讀 39,690評(píng)論 1 348
  • 序言:一個(gè)原本活蹦亂跳的男人離奇死亡嫁佳,死狀恐怖,靈堂內(nèi)的尸體忽然破棺而出谷暮,到底是詐尸還是另有隱情蒿往,我是刑警寧澤,帶...
    沈念sama閱讀 35,411評(píng)論 5 343
  • 正文 年R本政府宣布湿弦,位于F島的核電站瓤漏,受9級(jí)特大地震影響,放射性物質(zhì)發(fā)生泄漏。R本人自食惡果不足惜蔬充,卻給世界環(huán)境...
    茶點(diǎn)故事閱讀 41,004評(píng)論 3 325
  • 文/蒙蒙 一蝶俱、第九天 我趴在偏房一處隱蔽的房頂上張望。 院中可真熱鬧饥漫,春花似錦榨呆、人聲如沸。這莊子的主人今日做“春日...
    開封第一講書人閱讀 31,659評(píng)論 0 22
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至皿哨,卻和暖如春浅侨,著一層夾襖步出監(jiān)牢的瞬間,已是汗流浹背证膨。 一陣腳步聲響...
    開封第一講書人閱讀 32,812評(píng)論 1 268
  • 我被黑心中介騙來泰國打工如输, 沒想到剛下飛機(jī)就差點(diǎn)兒被人妖公主榨干…… 1. 我叫王不留,地道東北人央勒。 一個(gè)月前我還...
    沈念sama閱讀 47,693評(píng)論 2 368
  • 正文 我出身青樓不见,卻偏偏與公主長得像,于是被迫代替她去往敵國和親崔步。 傳聞我的和親對(duì)象是個(gè)殘疾皇子稳吮,可洞房花燭夜當(dāng)晚...
    茶點(diǎn)故事閱讀 44,577評(píng)論 2 353

推薦閱讀更多精彩內(nèi)容