甲級(jí)-1003 Emergency (25 分)

題目:

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N?1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1 , c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2?? .

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2 , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

解題思路:

使用迪杰斯特拉算法肛捍,需要注意統(tǒng)計(jì)保存最短路徑的數(shù)量之众,最后選擇權(quán)值最高(途徑結(jié)點(diǎn)救援隊(duì)數(shù)量總和最多)的路徑。

代碼:

編譯器:C++(g++)

#include <iostream>
#include <vector>
using namespace std;
typedef vector<int> RoadInfo;

//查找未被訪問過的棺禾,距離c1路徑長度最小的結(jié)點(diǎn)
int findMin(vector<RoadInfo> &roadLst)
{
    int min=-1,index=-1;
    int n=roadLst.size();
    for(int i=0;i!=n;++i)
    {
        if(roadLst[i][n+2]!=1&&roadLst[i][n+1]!=-1)
        {
            if(-1==min)
            {
                min=roadLst[i][n+1];
                index=i;
            }
            else
            {
                if(roadLst[i][n+1]<min)
                {
                    min=roadLst[i][n+1];
                    index=i;
                }
            }
        }
    }
    if(index!=-1)
        roadLst[index][n+2]=1;
    return index;
}
int main()
{
    int n,m,c1,c2;
    cin>>n>>m>>c1>>c2;
    vector<int> numOfCity;
    for(int i=0;i!=n;++i)
    {
        int tmp;
        cin>>tmp;
        numOfCity.push_back(tmp);
    }
    vector<vector<int>> road;
    for(int i=0;i!=m;++i)
    {
        int t1,t2,t3;
        cin>>t1>>t2>>t3;
        vector<int> t;
        t.push_back(t1);
        t.push_back(t2);
        t.push_back(t3);
        road.push_back(t);
        //swap一下t[0]和t[1]再push,這樣后面只用遍歷t[0]就可以了
        std::swap(t[0],t[1]);
        road.push_back(t);
    }
    //c1到此節(jié)點(diǎn)的路程信息,0~n-1表示經(jīng)過的節(jié)點(diǎn)蛀醉,n為同等長度的路徑數(shù)量,n+1為路徑長度,n+2為是否以此節(jié)點(diǎn)為中心訪問過
    RoadInfo ri(n+3,-1);
    vector<RoadInfo> roadLst(n,ri);
    for(int i=0;i!=2*m;++i)
    {
        //以c1為出發(fā)點(diǎn)遍歷
        if(c1==road[i][0])
        {
            roadLst[road[i][1]][c1]=1;
            roadLst[road[i][1]][n]=1;
            roadLst[road[i][1]][n+1]=road[i][2];
        }
    }
    roadLst[c1][n]=1;   //c1到c1的路徑只有1條
    roadLst[c1][n+1]=0; //c1到c1的距離為0
    roadLst[c1][n+2]=1; //將c1結(jié)點(diǎn)置為已訪問狀態(tài)
    while(1)
    {
        int min=findMin(roadLst);   //查找未被訪問過的滞欠,距離c1路徑長度最小的結(jié)點(diǎn)
        if(-1==min||min==c2)    //如果min==c2,則表明此時(shí)c1到c2的最短路徑已經(jīng)確認(rèn)
        {
            break;
        }
        for(int i=0;i!=2*m;++i)
        {
            if(min==road[i][0])
            {
                if(-1==roadLst[road[i][1]][n+1])
                {
                    roadLst[road[i][1]]=roadLst[min];
                    roadLst[road[i][1]][min]=1;
                    roadLst[road[i][1]][n+1]+=road[i][2];
                    roadLst[road[i][1]][n+2]=-1;
                }
                else
                {
                    if(roadLst[road[i][1]][n+1]>roadLst[min][n+1]+road[i][2])
                    {
                        int visited=roadLst[road[i][1]][n+2];
                        roadLst[road[i][1]]=roadLst[min];
                        roadLst[road[i][1]][min]=1;
                        roadLst[road[i][1]][n+1]+=road[i][2];
                        roadLst[road[i][1]][n+2]=visited;
                    }
                    //路徑長度相同筛璧,則比較哪條路上的救援隊(duì)數(shù)量多惹恃,選擇多的那一條
                    else if(roadLst[road[i][1]][n+1]==roadLst[min][n+1]+road[i][2])
                    {
                        int sumOfRoad=roadLst[road[i][1]][n]+roadLst[min][n];
                        int curTeams=0,preTeams=0;
                        for(int j=0;j!=n;++j)
                        {
                            if(1==roadLst[road[i][1]][j])
                                preTeams+=numOfCity[j];
                            if(1==roadLst[min][j])
                                curTeams+=numOfCity[j];
                        }
                        curTeams+=numOfCity[min];
                        if(curTeams>preTeams)
                        {
                            int visited=roadLst[road[i][1]][n+2];
                            roadLst[road[i][1]]=roadLst[min];
                            roadLst[road[i][1]][min]=1;
                            roadLst[road[i][1]][n+1]+=road[i][2];
                            roadLst[road[i][1]][n+2]=visited;
                        }
                        roadLst[road[i][1]][n]=sumOfRoad;
                    }
                }
            }
        }
    }
    int teams=0;
    for(int j=0;j!=n;++j)
    {
        if(1==roadLst[c2][j])
            teams+=numOfCity[j];
    }
    teams+=numOfCity[c2];
    cout<<roadLst[c2][n]<<" "<<teams<<endl;
    return 0;
}
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請聯(lián)系作者
  • 序言:七十年代末,一起剝皮案震驚了整個(gè)濱河市巫糙,隨后出現(xiàn)的幾起案子,更是在濱河造成了極大的恐慌参淹,老刑警劉巖,帶你破解...
    沈念sama閱讀 211,348評論 6 491
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件浙值,死亡現(xiàn)場離奇詭異恳不,居然都是意外死亡开呐,警方通過查閱死者的電腦和手機(jī)烟勋,發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 90,122評論 2 385
  • 文/潘曉璐 我一進(jìn)店門筐付,熙熙樓的掌柜王于貴愁眉苦臉地迎上來,“玉大人瓦戚,你說我怎么就攤上這事〗辖猓” “怎么了?”我有些...
    開封第一講書人閱讀 156,936評論 0 347
  • 文/不壞的土叔 我叫張陵哨坪,是天一觀的道長庸疾。 經(jīng)常有香客問我乍楚,道長,這世上最難降的妖魔是什么徒溪? 我笑而不...
    開封第一講書人閱讀 56,427評論 1 283
  • 正文 為了忘掉前任金顿,我火速辦了婚禮鲤桥,結(jié)果婚禮上,老公的妹妹穿的比我還像新娘茶凳。我一直安慰自己,他們只是感情好贮喧,可當(dāng)我...
    茶點(diǎn)故事閱讀 65,467評論 6 385
  • 文/花漫 我一把揭開白布。 她就那樣靜靜地躺著箱沦,像睡著了一般。 火紅的嫁衣襯著肌膚如雪谓形。 梳的紋絲不亂的頭發(fā)上,一...
    開封第一講書人閱讀 49,785評論 1 290
  • 那天寒跳,我揣著相機(jī)與錄音,去河邊找鬼冯袍。 笑死,一個(gè)胖子當(dāng)著我的面吹牛康愤,可吹牛的內(nèi)容都是我干的。 我是一名探鬼主播征冷,決...
    沈念sama閱讀 38,931評論 3 406
  • 文/蒼蘭香墨 我猛地睜開眼,長吁一口氣:“原來是場噩夢啊……” “哼肴捉!你這毒婦竟也來了?” 一聲冷哼從身側(cè)響起齿穗,我...
    開封第一講書人閱讀 37,696評論 0 266
  • 序言:老撾萬榮一對情侶失蹤饺律,失蹤者是張志新(化名)和其女友劉穎窃页,沒想到半個(gè)月后,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體脖卖,經(jīng)...
    沈念sama閱讀 44,141評論 1 303
  • 正文 獨(dú)居荒郊野嶺守林人離奇死亡,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點(diǎn)故事閱讀 36,483評論 2 327
  • 正文 我和宋清朗相戀三年袖扛,在試婚紗的時(shí)候發(fā)現(xiàn)自己被綠了。 大學(xué)時(shí)的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片蛆封。...
    茶點(diǎn)故事閱讀 38,625評論 1 340
  • 序言:一個(gè)原本活蹦亂跳的男人離奇死亡,死狀恐怖娶吞,靈堂內(nèi)的尸體忽然破棺而出,到底是詐尸還是另有隱情妒蛇,我是刑警寧澤,帶...
    沈念sama閱讀 34,291評論 4 329
  • 正文 年R本政府宣布绣夺,位于F島的核電站,受9級(jí)特大地震影響陶耍,放射性物質(zhì)發(fā)生泄漏。R本人自食惡果不足惜烈钞,卻給世界環(huán)境...
    茶點(diǎn)故事閱讀 39,892評論 3 312
  • 文/蒙蒙 一坤按、第九天 我趴在偏房一處隱蔽的房頂上張望毯欣。 院中可真熱鬧臭脓,春花似錦酗钞、人聲如沸来累。這莊子的主人今日做“春日...
    開封第一講書人閱讀 30,741評論 0 21
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽。三九已至领猾,卻和暖如春米同,著一層夾襖步出監(jiān)牢的瞬間,已是汗流浹背窍霞。 一陣腳步聲響...
    開封第一講書人閱讀 31,977評論 1 265
  • 我被黑心中介騙來泰國打工拯坟, 沒想到剛下飛機(jī)就差點(diǎn)兒被人妖公主榨干…… 1. 我叫王不留,地道東北人郁季。 一個(gè)月前我還...
    沈念sama閱讀 46,324評論 2 360
  • 正文 我出身青樓,卻偏偏與公主長得像梦裂,于是被迫代替她去往敵國和親。 傳聞我的和親對象是個(gè)殘疾皇子年柠,可洞房花燭夜當(dāng)晚...
    茶點(diǎn)故事閱讀 43,492評論 2 348

推薦閱讀更多精彩內(nèi)容