POJ 1244 Slots of Fun
The International Betting Machine company has just issued a new type of slot machine. The machine display consists of a set of identical circles placed in a triangular shape. An example with four rows is shown below. When the player pulls the lever, the machine places a random letter in the center of each circle. The machine pays off whenever any set of identical letters form the vertices of an equilateral triangle. In the example below, the letters 'a' and 'c' satisfy this condition.
In order to prevent too many payoffs, the electronics in the machine ensures that no more than 3 of any letter will appear in any display configuration.
IBM is manufacturing several models of this machine, with varying number of rows in the display, and they are having trouble writing code to identify winning configurations. Your job is to write that code.
Input
Input will consist of multiple problem instances. Each instance will start with an integer n indicating the number of rows in the display. The next line will contain n(n + 1)/2 letters of the alphabet (all lowercase) which are to be stored in the display row-wise, starting from the top. For example, the display above would be specified as
4
abccddadca
The value of n will be between 1 and 12, inclusive. A line with a single 0 will terminate input.
Output
For each problem instance, output all letters which form equilateral triangles on a single line, in alphabetical order. If no such letters exist, output "LOOOOOOOOSER!".
Sample Input
4
abccddadca
6
azdefccrhijrrmznzocpq
2
abc
0
Sample Output
ac
crz
LOOOOOOOOSER!
題目的大意就是要判斷輸入中字母相同且構(gòu)成等邊三角形三點的字母有哪些,
等邊三角形等邊三角形统倒,就是三邊相等就行了蜕径,數(shù)據(jù)也小,直接暴力就行启盛,最主要的問題是求兩點間的距離,這里可以把整個三角形就是一個60°的斜坐標(biāo)系,推一下斜坐標(biāo)系兩點距離就可以了
然后到這里就把ab的距離求出來了求类,直接暴力判斷三點距離相等就行了
#include<iostream>
#include<cstring>
using namespace std;
char record[13][13];
int zmnum[26];
int zm[26][4][2];
int result[26];
int getdis(int x1,int x2,int y1,int y2){
return (x2-x1)*(x2-x1)+(y2-y1)*(y2-y1)-(x2-x1)*(y2-y1);
}
int main(){
int n;
while(cin>>n&&n){
memset(result,0,sizeof(result));
memset(zm,0,sizeof(zm));
memset(zmnum,0,sizeof(zmnum));
for(int i=0;i<n;i++){
for(int j=0;j<=i;j++){
cin>>record[i][j];
}
}
if(n==1){
cout<<"LOOOOOOOOSER!"<<endl;
continue;
}
double layer=((n+1)*n)/2;
for(int i=0;i<n;i++){
for(int j=0;j<=i;j++){
char c=record[i][j];
zm[c-'a'][zmnum[c-'a']][0]=i;
zm[c-'a'][zmnum[c-'a']++][1]=j;
}
}
bool loser=true;
for(int i=0;i<26;i++){
char c=i+'a';
if(zmnum[i]<3)continue;
int l1=getdis(zm[i][0][0],zm[i][1][0],zm[i][0][1],zm[i][1][1]);
int l2=getdis(zm[i][1][0],zm[i][2][0],zm[i][1][1],zm[i][2][1]);
int l3=getdis(zm[i][2][0],zm[i][0][0],zm[i][2][1],zm[i][0][1]);
if(l1==l2&&l2==l3)loser=false,cout<<c;
}
if(loser)cout<<"LOOOOOOOOSER!";
cout<<endl;
}
return 0;
}