Phone List
Time Limit: 1000MS
Memory Limit: 65536K
Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:
? Emergency 911
? Alice 97 625 999
? Bob 91 12 54 26
In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output "YES" if the list is consistent, or "NO" otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES
Source
Nordic 2007
題意:
給n個(gè)電話簿,每個(gè)電話簿中有m個(gè)電話號(hào)碼,如果電話簿中有某一個(gè)號(hào)碼是無(wú)效的(即另一個(gè)號(hào)碼為其前綴)濒生,則輸出NO佩耳,如果沒(méi)有則輸出YES频蛔。
思路:
字典樹(shù)灵迫。
#include<cstdio>
#include<cstring>
using namespace std;
char phone[10 + 5];
bool yes;
int cnt;
struct Node {
int next[10];
int has;
}node[1000000 + 10];
void build(int root, char* str, bool hasNew) {
int th = str[0] - '0';
if (node[root].next[th] == 0) {
node[root].next[th] = cnt++;
hasNew = true;
}
if (node[node[root].next[th]].has == 1)
yes = false;
if (str[1] == '\0') {
node[node[root].next[th]].has = 1;
if (!hasNew)
yes = false;
return;
}
build(node[root].next[th], str + 1, hasNew);
return;
}
int main() {
int T, n;
scanf("%d", &T);
while (T--) {
memset(node, 0, sizeof(node));
cnt = 2;
yes = true;
scanf("%d", &n);
for (int i = 0; i < n; ++i) {
scanf("%s", phone);
build(1, phone, false);
}
if (yes)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}