1001. A+B Format (20)

時間限制
400 ms
內(nèi)存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991

AC代碼:

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;

int main(int argc, const char * argv[]) {
    int a, b, sum;
    cin >> a >> b;
    sum = a + b;
    
    string str;
    str = to_string(sum);
    if(str[0] == '-') {
        cout << '-';
        str.erase(0,1);
    }
    reverse(str.begin(), str.end() );
    int len = (int)str.size();
    for(int i = 3; i < len; i += 3) {
        str.insert(i, ",");
        i++;
        len++;
    }
    reverse(str.begin(), str.end() );
    cout << str << endl;
    return 0;
}

string字符串操作:

  • erase
    原型:
    (1)string& erase ( size_t pos = 0, size_t n = npos );
    (2)iterator erase ( iterator position );
    (3)iterator erase ( iterator first, iterator last );
    用法:
    (1)erase(pos,n); 刪除從pos開始的n個字符恰梢,比如erase(0,1)就是刪除第一個字符
    (2)erase(position);刪除position處的一個字符(position是個string類型的迭代器)
    (3)erase(first,last);刪除從first到last之間的字符(first和last都是迭代器)

  • insert
    原型:
    string &insert(int p0, const char *s);
    string &insert(int p0, const char *s, int n);
    string &insert(int p0,const string &s);
    string &insert(int p0,const string &s, int pos, int n);
    //前4個函數(shù)在p0位置插入字符串s中pos開始的前n個字符
    string &insert(int p0, int n, char c);//此函數(shù)在p0處插入n個字符c
    iterator insert(iterator it, char c);//在it處插入字符c渴丸,返回插入后迭代器的位置
    void insert(iterator it, const_iterator first, const_iterator last);//在it處插入[first,last)之間的字符
    void insert(iterator it, int n, char c);//在it處插入n個字符c

  • to_string函數(shù) C++11 新增方法
    string to_string (int val);
    string to_string (long val);
    string to_string (long long val);
    string to_string (unsigned val);
    string to_string (unsigned long val);
    string to_string (unsigned long long val);
    string to_string (float val);
    string to_string (double val);
    string to_string (long double val)

  • reverse函數(shù)
    數(shù)組轉(zhuǎn)置 reverse(v.begin(),v.end())

提供另一種解法

//
//  main.cpp
//  pat
//
//  Created by yaojies on 16/8/16.
//  Copyright ? 2016年 yaojies. All rights reserved.
//

#include <iostream>
#include <iomanip>
using namespace std;

int main(int argc, const char * argv[]) {
    int numA, numB, result;
    void functionOfPrint(int result);
    cin >> numA >> numB;
    result = numA + numB;
    //print "-" if result < 0
    if(result<0){
        cout << "-";
        result = -result;
    }
    functionOfPrint(result);
    cout << endl;
    return 0;
}
void functionOfPrint(int result){
    if(result>999){
        functionOfPrint(result/1000);
        cout << ",";
        cout << setfill('0')<<setw(3) << result%1000;
    }else{
        cout << result;
    }
}

最后編輯于
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請聯(lián)系作者
  • 序言:七十年代末,一起剝皮案震驚了整個濱河市,隨后出現(xiàn)的幾起案子番电,更是在濱河造成了極大的恐慌盛杰,老刑警劉巖,帶你破解...
    沈念sama閱讀 206,311評論 6 481
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件拾徙,死亡現(xiàn)場離奇詭異,居然都是意外死亡感局,警方通過查閱死者的電腦和手機尼啡,發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 88,339評論 2 382
  • 文/潘曉璐 我一進店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來询微,“玉大人玄叠,你說我怎么就攤上這事⊥靥幔” “怎么了读恃?”我有些...
    開封第一講書人閱讀 152,671評論 0 342
  • 文/不壞的土叔 我叫張陵,是天一觀的道長代态。 經(jīng)常有香客問我寺惫,道長,這世上最難降的妖魔是什么蹦疑? 我笑而不...
    開封第一講書人閱讀 55,252評論 1 279
  • 正文 為了忘掉前任西雀,我火速辦了婚禮,結(jié)果婚禮上歉摧,老公的妹妹穿的比我還像新娘艇肴。我一直安慰自己,他們只是感情好叁温,可當(dāng)我...
    茶點故事閱讀 64,253評論 5 371
  • 文/花漫 我一把揭開白布再悼。 她就那樣靜靜地躺著,像睡著了一般膝但。 火紅的嫁衣襯著肌膚如雪冲九。 梳的紋絲不亂的頭發(fā)上,一...
    開封第一講書人閱讀 49,031評論 1 285
  • 那天跟束,我揣著相機與錄音莺奸,去河邊找鬼。 笑死冀宴,一個胖子當(dāng)著我的面吹牛灭贷,可吹牛的內(nèi)容都是我干的。 我是一名探鬼主播略贮,決...
    沈念sama閱讀 38,340評論 3 399
  • 文/蒼蘭香墨 我猛地睜開眼甚疟,長吁一口氣:“原來是場噩夢啊……” “哼仗岖!你這毒婦竟也來了?” 一聲冷哼從身側(cè)響起古拴,我...
    開封第一講書人閱讀 36,973評論 0 259
  • 序言:老撾萬榮一對情侶失蹤,失蹤者是張志新(化名)和其女友劉穎真友,沒想到半個月后黄痪,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體,經(jīng)...
    沈念sama閱讀 43,466評論 1 300
  • 正文 獨居荒郊野嶺守林人離奇死亡盔然,尸身上長有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點故事閱讀 35,937評論 2 323
  • 正文 我和宋清朗相戀三年桅打,在試婚紗的時候發(fā)現(xiàn)自己被綠了。 大學(xué)時的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片愈案。...
    茶點故事閱讀 38,039評論 1 333
  • 序言:一個原本活蹦亂跳的男人離奇死亡挺尾,死狀恐怖,靈堂內(nèi)的尸體忽然破棺而出站绪,到底是詐尸還是另有隱情遭铺,我是刑警寧澤,帶...
    沈念sama閱讀 33,701評論 4 323
  • 正文 年R本政府宣布恢准,位于F島的核電站魂挂,受9級特大地震影響,放射性物質(zhì)發(fā)生泄漏馁筐。R本人自食惡果不足惜涂召,卻給世界環(huán)境...
    茶點故事閱讀 39,254評論 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望敏沉。 院中可真熱鬧果正,春花似錦、人聲如沸盟迟。這莊子的主人今日做“春日...
    開封第一講書人閱讀 30,259評論 0 19
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽攒菠。三九已至轮锥,卻和暖如春,著一層夾襖步出監(jiān)牢的瞬間要尔,已是汗流浹背舍杜。 一陣腳步聲響...
    開封第一講書人閱讀 31,485評論 1 262
  • 我被黑心中介騙來泰國打工, 沒想到剛下飛機就差點兒被人妖公主榨干…… 1. 我叫王不留赵辕,地道東北人既绩。 一個月前我還...
    沈念sama閱讀 45,497評論 2 354
  • 正文 我出身青樓,卻偏偏與公主長得像还惠,于是被迫代替她去往敵國和親饲握。 傳聞我的和親對象是個殘疾皇子,可洞房花燭夜當(dāng)晚...
    茶點故事閱讀 42,786評論 2 345

推薦閱讀更多精彩內(nèi)容