As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.
Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N?1), M - the number of roads, C?1?? and C2?? - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c
?1
?? , c
?2
?? and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C?1?? to C2?? .
Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C?1?? and C?2?? , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output:
2 4
code
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int dis[500],num[500],weight[500],w[500];
int adj[500][500];
int visit[500];
const int inf = 999999;
int n,m,origin,dest;
scanf("%d%d%d%d",&n,&m,&origin,&dest);
for(int i=0;i<n;i++)
{
scanf("%d",&weight[i]);
}
fill(adj[0],adj[0]+500*500,inf);
fill(dis,dis+500,inf);
fill(num,num+500,0);
int a,b,c;
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&a,&b,&c);
adj[a][b] = adj[b][a] = c;
}
dis[origin] = 0;
w[origin] = weight[origin];
num[origin] = 1;
for(int i=0;i<n;i++)
{
int x=-1, minn=inf;
for(int j=0;j<n;j++)
{
if(!visit[j] && dis[j]<minn) {
minn = dis[j];
x = j;
}
}
visit[x] = 1;
for(int y=0;y<n;y++)
{
if(dis[y]>dis[x]+adj[x][y]) {
dis[y] = dis[x] + adj[x][y];
num[y] = num[x];
w[y] = weight[y]+w[x];
}else if(dis[y] == dis[x]+adj[x][y] && dis[x]!=0) {
num[y] = num[y] + num[x];
if(w[x]+weight[y]>w[y]) {
w[y] = w[x] + weight[y];
}
}
}
// printf("%d\n",i);
// printf("num:");
// for(int k=0;k<n;k++) printf("%d ",num[k]);
// printf("\n");
// printf("dis:");
// for(int k=0;k<n;k++) printf("%d ",dis[k]);
// printf("\n");
// printf("w:");
// for(int k=0;k<n;k++) printf("%d ",w[k]);
// printf("\n");
}
// for(int i=0;i<n;i++)
// {
// for(int j=0;j<n;j++)
// {
// printf("%d ",adj[i][j]);
// }
// printf("\n");
// }
printf("%d %d", num[dest],w[dest]);
return 0;
}
note
- Dijkstra 算法
假設(shè)我們要求從A到F的最短路個數(shù)和最短路上最大的點權(quán)和
上圖的鄰接矩陣表示:
點權(quán)數(shù)組
每次迭代找到數(shù)組中最小值,并對與該節(jié)點相連的邊進(jìn)行松弛
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 0 | 0 | 0 | 0 | 0 |
dis | 0 | inf | inf | inf | inf | inf |
num | 1 | 0 | 0 | 0 | 0 | 0 |
visit | 0 | 0 | 0 | 0 | 0 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 5 | 6 | 0 |
dis | 0 | 1 | 2 | 3 | 4 | inf |
num | 1 | 1 | 1 | 1 | 1 | 0 |
visit | 1 | 0 | 0 | 0 | 0 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 5 | 6 | 9 |
dis | 0 | 1 | 2 | 3 | 4 | 4 |
num | 1 | 1 | 1 | 1 | 1 | 1 |
visit | 1 | 1 | 0 | 0 | 0 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 8 | 6 | 10 |
dis | 0 | 1 | 2 | 3 | 4 | 4 |
num | 1 | 1 | 1 | 2 | 1 | 2 |
visit | 1 | 1 | 1 | 0 | 0 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 8 | 6 | 14 |
dis | 0 | 1 | 2 | 3 | 4 | 4 |
num | 1 | 1 | 1 | 2 | 1 | 4 |
visit | 1 | 1 | 1 | 1 | 0 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 8 | 6 | 14 |
dis | 0 | 1 | 2 | 3 | 4 | 4 |
num | 1 | 1 | 1 | 2 | 1 | 4 |
visit | 1 | 1 | 1 | 1 | 1 | 0 |
A | B | C | D | E | F | |
---|---|---|---|---|---|---|
w | 1 | 3 | 4 | 8 | 6 | 14 |
dis | 0 | 1 | 2 | 3 | 4 | 4 |
num | 1 | 1 | 1 | 2 | 1 | 4 |
visit | 1 | 1 | 1 | 1 | 1 | 1 |
-
fill 和 memset
fill 可以填充任何值藕各,包含在<algorithm>
中
對vector:fill(v.begin(), v.end(), -1)
對一維數(shù)組:fill(arr, arr + 10, 2)
對二維數(shù)組:fill(adj[0],adj[0]+500*500,inf);
memset按照字節(jié)進(jìn)行填充臊岸,一般用來填充char型數(shù)組,也經(jīng)常用于填充int型的全0或全-1操作蕉饼,包含在<cstring>
中
對數(shù)組:memset(a, 0, sizeof(a))