A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.
Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.
One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players' info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.
Output Specification:
For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.
Sample Input:
9
20:52:00 10 0
08:00:00 20 0
08:02:00 30 0
20:51:00 10 0
08:10:00 5 0
08:12:00 10 1
20:50:00 10 0
08:01:30 15 1
20:53:00 10 1
3 1
2
Sample Output:
08:00:00 08:00:00 0
08:01:30 08:01:30 0
08:02:00 08:02:00 0
08:12:00 08:16:30 5
08:10:00 08:20:00 10
20:50:00 20:50:00 0
20:51:00 20:51:00 0
20:52:00 20:52:00 0
3 3 2
題目大意
k張桌子奠宜,球員到達(dá)后總是選擇編號最小的桌子。如果訓(xùn)練時間超過2h會被壓縮成2h,如果到達(dá)時候沒有球桌空閑就變成隊(duì)列等待。k張桌子中m張是vip桌扩劝,如果vip桌子有空閑蛙婴,而且隊(duì)列里面有vip成員,那么等待隊(duì)列中的第一個vip球員會到最小的vip球桌訓(xùn)練唧取。如果vip桌子空閑但是沒有vip來展辞,那么就分配給普通的人奥邮。如果沒有vip球桌空閑,那么vip球員就當(dāng)作普通人處理罗珍。
給出每個球員的到達(dá)時間洽腺、要玩多久、是不是vip(是為1不是為0)覆旱。給出球桌數(shù)和所有vip球桌的編號蘸朋,QQ所有在關(guān)門前得到訓(xùn)練的球員的到達(dá)時間、訓(xùn)練開始時間通殃、等待時長(取整數(shù)度液,四舍五入)厕宗,營業(yè)時間為8點(diǎn)到21點(diǎn)画舌。如果再21點(diǎn)后還沒有開始玩的人,就不再玩已慢,不需要輸出~
————————————————
摘自CSDN博主「柳婼」的原創(chuàng)文章
原文鏈接:https://blog.csdn.net/liuchuo/article/details/54576965
測試點(diǎn)分析
一開始錯了四個點(diǎn):測試點(diǎn)3曲聂、測試點(diǎn)5、測試點(diǎn)7佑惠、測試點(diǎn)8
測試點(diǎn)3:只有一個人來并關(guān)門了
// 測試點(diǎn)3樣例
1
21:00:00 10 1
3 0
測試點(diǎn)5朋腋、7:都是vip用戶要選擇第一張空閑的vip桌,注意時間可以取等膜楷,即剛好打完到了
測試點(diǎn)8:最后計(jì)算等待時間的時候>=30向上進(jìn)1旭咽,用(start-arrive+30)/60就行了
AC代碼
#include<bits/stdc++.h>
using namespace std;
struct cus{
int arri, play, vip;
int start;
};
bool cmp1(cus a, cus b){
return a.arri < b.arri;
}
bool cmp2(cus a, cus b){
return a.start<b.start;
}
void prt(int x){
int h, m, s;
h = x/3600;
m = x/60 -h*60;
s = x%60;
printf("%02d:%02d:%02d ", h, m, s);
}
int main(){
int n, m, k;
scanf("%d", &n);
vector<cus> data(n);
for(int i=0; i<n; i++){
int h, m, s;
scanf("%d:%d:%d %d %d", &h, &m, &s, &data[i].play, &data[i].vip);
data[i].play = min(120, data[i].play)*60; //測試點(diǎn)4
data[i].arri = h*3600 + m*60 +s;
}
scanf("%d %d", &m, &k);
vector<int> times(m, 8*3600);
vector<int> cnt(m);
vector<bool> is_vip(m, false);
for(int i=0; i<k; i++){
int t;
scanf("%d", &t);
is_vip[t-1] = true;
}
sort(data.begin(), data.end(), cmp1);
for(int i=0; i<n; i++){
if(data[i].start) continue;
int mint=21*3600, table=-1, player=i;
for(int j=0; j<m; j++){
if(times[j]<mint){
table = j;
mint = times[j];
}
}
if(table==-1) data[i].start = mint;
else{
if(is_vip[table]&&!data[i].vip){
for(int j=i; j<n&&data[j].arri<=mint&&player==i; j++) if(data[j].vip&&!data[j].start) player=j;
if(player!=i) i--;
}
else if(data[i].vip&&!is_vip[table]){
for(int j=0; j<m; j++){ //測試點(diǎn)5在vip用戶用第一張空閑的vip桌
if(times[j]<=data[i].arri&&is_vip[j]){ //測試點(diǎn)7在這個等于號
table = j; break;
}
}
}
data[player].start = max(mint, data[player].arri);
times[table] = data[player].start + data[player].play;
if(data[player].start<21*3600) cnt[table]++; //測試點(diǎn)3在這個判斷,第一個用戶就超過21點(diǎn)不能計(jì)數(shù)
}
}
sort(data.begin(), data.end(), cmp2);
for(int i=0; i<n; i++){
if(data[i].start>=21*3600) continue;
prt(data[i].arri);
prt(data[i].start);
printf("%d\n", (data[i].start-data[i].arri+30)/60); //測試點(diǎn)8在這個分鐘的四舍五入
}
for(int i=0; i<m; i++) printf("%d%s", cnt[i], i==m-1?"\n":" ");
return 0;
}