1004 Counting Leaves (30)
A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input
Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.
Output
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.
Sample Input
2 1
01 1 02
Sample Output
0 1
分析:最開始我是想用圖來保存數(shù)據(jù)肉拓,然后從頂點1開始進行圖的bfs县匠,bfs的同時計算每行葉子節(jié)點的個數(shù)汁政。實現(xiàn)起來比較復(fù)雜。看了柳婼大神的解題媚值,才想起來使用vector。兩種都是使用圖來保存數(shù)據(jù),但vector是可變長度的诗良。而且API較多,使用起來很方便鲁驶。
#include <bits/stdc++.h>
#define INF 999999999
using namespace std;
vector<int> matrix[101];
int record[101] = {0};
int deepest = -1;
void dfs(int index, int depth)
{
if(matrix[index].size() == 0){
record[depth]++;
deepest = deepest>depth?deepest:depth;
return;
}
for(int i = 0; i < matrix[index].size(); i++)
dfs(matrix[index][i], depth+1);
}
int main()
{
int n, m; //樹的節(jié)點鉴裹,樹的非葉節(jié)點
cin >> n >> m;
int id, nn, i, j, temp;
for(i = 0; i < m; i++){
cin >> id >> nn;
for(j = 0; j < nn; j++){
cin >> temp;
matrix[id].push_back(temp);
}
}
dfs(1, 0);
cout << record[0];
for(i = 1; i <= deepest; i++)
cout << " " << record[i];
return 0;
}