Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
分析:
題目要求先輸入考場個數(shù)驱负,再輸入每個考場人數(shù)和各個考場的考生分?jǐn)?shù)猪贪。最終輸出所有學(xué)生的注冊號、總排名汉矿、考場號愕乎、考場排名亮蒋。
按考場讀入學(xué)生信息后,立即計算考場排名妆毕。再對所有學(xué)生進(jìn)行排序慎玖,輸出最終結(jié)果。
C++:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 30010;
struct Student {
char id[15];
int score, loc, locRank, finalRank;//id,分?jǐn)?shù)笛粘,考場號趁怔,考場排名,總排名
} stus[maxn];
bool cmp(Student a, Student b) {
if (a.score != b.score) {
return a.score > b.score;
} else {
return strcmp(a.id, b.id) < 0;
}
}
int main() {
int n, k, num = 0;
scanf("%d", &n);
for (int i = 1; i <= n; i++) {
scanf("%d", &k);
for (int j = 0; j < k; j++) {
scanf("%s %d", &stus[num].id, &stus[num].score);
stus[num].loc = i;
num++;
}
//考場內(nèi)排名
sort(stus + num - k, stus + num, cmp);
stus[num - k].locRank = 1;
for (int j = num - k + 1; j < num; j++) {
if (stus[j].score == stus[j - 1].score) {
stus[j].locRank = stus[j - 1].locRank;
} else {
stus[j].locRank = j + 1 - (num - k);
}
}
}
sort(stus, stus + num, cmp);
stus[0].finalRank = 1;
for (int i = 1; i < num; i++) {
if (stus[i].score == stus[i - 1].score) {
stus[i].finalRank = stus[i - 1].finalRank;
} else {
stus[i].finalRank = i + 1;
}
}
printf("%d\n", num);
for (int i = 0; i < num; i++) {
printf("%s %d %d %d\n", stus[i].id, stus[i].finalRank, stus[i].loc, stus[i].locRank);
}
return 0;
}