統(tǒng)計給定文本文件中漢字的個數(shù)胚鸯。
Input
輸入文件首先包含一個整數(shù)n玄渗,表示測試實例的個數(shù),然后是n段文本仪媒。
Output
對于每一段文本沉桌,輸出其中的漢字的個數(shù),每個測試實例的輸出占一行算吩。
[Hint:]從漢字機內(nèi)碼的特點考慮~
Sample Input
2
WaHaHa! WaHaHa! 今年過節(jié)不說話要說只說普通話WaHaHa! WaHaHa!
馬上就要期末考試了Are you ready?
Sample Output
14
9
程序說明:
漢字占兩個字節(jié)留凭,且為負(fù)數(shù)(機內(nèi)碼最高位是1)。
代碼如下:
#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int main() {
int n;
scanf("%d", &n);
getchar();
while(n--) {
string a;
int cnt = 0;
getline(cin, a);
for(int i = 0; i < a.length(); i++) {
if(a[i] < 0)
cnt++;
}
printf("%d\n", cnt / 2);
}
return 0;
}