Pat1002 A+B for Polynomials(25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
說(shuō)一下遇到的問(wèn)題:
- 格式錯(cuò)誤规个,要求跟輸入一樣诅妹,浮點(diǎn)書(shū)表留一位小數(shù)冯事,最后不能由空格
- 沒(méi)有考慮到如果兩個(gè)多項(xiàng)式相加孝偎,會(huì)出現(xiàn)系數(shù)為0的情況栽连,此時(shí)不再記錄(多慮的是demo分明由0輸出了么翩伪,但是它是指數(shù)不是系數(shù))
- 數(shù)據(jù)的類型誉己,一定盡量開(kāi)始就合適
我的代碼
#include <map>
#include <iostream>
#include<iterator>
#include <iomanip>
using namespace std;
map<int,double> da;
int main()
{
int size;
int tmp1;
double tmp2;
cin>>size;
for(int i=0;i<size;++i)
{
cin>>tmp1;
cin>>tmp2;
da[tmp1]+=tmp2;
}
cin>>size;
for(int i=0;i<size;++i)
{
cin>>tmp1;
cin>>tmp2;
da[tmp1]+=tmp2;
if(da[tmp1]==0)
da.erase(tmp1);
}
cout<<da.size();
for(map<int,double>::reverse_iterator s=da.rbegin();s!=da.rend();++s)
{
cout<<fixed<<setprecision(1);
cout<<" "<<s->first<<" "<<s->second;
}
cout<<endl;
return 0;
}