題目來源HDU - 2104
一道判斷互質(zhì)的題目
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
Output
For each input case, you should only the result that Haha can find the handkerchief or not.
Sample Input
3 2
-1 -1
Sample Output
YES
輸入兩個數(shù)n,m.共有n個人,Haha每隔m-1個人查找一次拾酝,問經(jīng)過無數(shù)次循環(huán)后,Haha是否可以遍歷所有人,若可以輸出YES,否則輸出NO辰妙。
起初的思路為計算第一次完成一次循環(huán)后,Haha所尋找人的序號作為flag1.然后對一次完整的循環(huán)所有序號與該序號對比,若相等則表示只能在幾個人之間循環(huán)秫筏,無法遍歷所有人,否則可以挎挖。
思路完全是通過找規(guī)律找到的跳昼,沒有證明思路的正確性。后來上網(wǎng)查需要證明n和m兩個數(shù)互質(zhì)肋乍,即n和m最大公約數(shù)為1
因為每次循環(huán)遍歷的人的序號一定是n和m最大公約數(shù)的倍數(shù)鹅颊。所以只要滿足最大公約數(shù)為1,即可遍歷所有人墓造。
判斷互質(zhì)的方法為輾轉(zhuǎn)相除法
互質(zhì)數(shù)定義:
- 兩個數(shù)的公因數(shù)只有1的兩個非零自然數(shù),叫做互質(zhì)數(shù)堪伍。
- 多個數(shù)的若干個最大公因數(shù)只有1的正整數(shù),叫做互質(zhì)數(shù)
- 兩個不同的質(zhì)數(shù)觅闽,為互質(zhì)數(shù)
- 1和任何自然數(shù)互質(zhì)帝雇。
- 任何相鄰的兩個數(shù)互質(zhì)。
具體代碼如下:
#include<stdio.h>
int main()
{
long long n,m;
while (scanf("%lld %lld", &n, &m) && n != -1 && m != -1)
{
//確保n最大
if (n < m)
{
n = m + n;
m = n - m;
n = n - m;
}
while (n%m!=1)
{
if (n%m == 0) //n是m的倍數(shù)
break;
else
{
n = n%m;
n = n + m;
m = n - m;
n = n - m;
}
}
if (n%m==0)
{
printf("POOR Haha\n");
}
else
{
printf("YES\n");
}
}
return 0;
}
ACM新手蛉拙,如有說錯或可以改進的地方請大家不吝賜教尸闸!