題目
1002 A+B for Polynomials (25 分)
This time, you are supposed to find A+B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N
?1
?? a
?N
?1
??
?? N
?2
?? a
?N
?2
??
?? ... N
?K
?? a
?N
?K
??
??
where K is the number of nonzero terms in the polynomial, N
?i
?? and a
?N
?i
??
?? (i=1,2,?,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10锦茁,0≤N
?K
?? <?<N
?2
?? <N
?1
?? ≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 2 1.5 1 2.9 0 3.2
分析
就是一個(gè)多項(xiàng)式相加的問(wèn)題攘轩,要注意的是相抵消為0的項(xiàng)是不計(jì)入不輸出的。
這邊使用map實(shí)現(xiàn)蜻势,并對(duì)map進(jìn)行排序輸出撑刺,鞏固了一下map的使用方法
代碼
#include<iostream>
#include<map>
using namespace std;
int main(){
map<int,double,greater<int>> m;
int k1,k2;
cin>>k1;
for(int i=0;i<k1;i++){
int n;double a;
cin>>n>>a;
m[n]=a;
}
cin>>k2;
for(int i=0;i<k2;i++){
int n;double a;
cin>>n>>a;
if(m.count(n)){
m[n]+=a;
if(m[n]==0){
m.erase(n);
}
}else{
m[n]=a;
}
}
cout<<m.size();
map<int,double>::iterator it=m.begin();
while(it!=m.end()){
if(it->second!=0){
printf(" %d %.1f",it->first,it->second);
}
it++;
}
}