The Suspects
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n?1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1
題意:
0是公認(rèn)的懷疑人资盅,和他一組的也算是懷疑人举哟,被懷疑的一組的人在其他組耕腾,那么他們也變成懷疑人了筋现。
思路:聯(lián)通塊問(wèn)題悟衩,把一個(gè)組的連一起,組里的人在其他組惠昔,也連起來(lái)挑势。然后找和0連起來(lái)的人。
#include<stdio.h>
int s1[30005];
int find(int x)
{
if(x==s1[x])
return x;
else
return s1[x]=find(s1[x]);
}
int main()
{
int n,m,i,j,s,count,t,x,y;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
for(i=0;i<=n;i++)
{
s1[i]=i;
}
for(i=0;i<m;i++)
{
scanf("%d",&t);
scanf("%d",&x); //把一個(gè)組連在一起
for(j=1;j<t;j++)
{
scanf("%d",&y);
x=find(x);
y=find(y);
if(x!=y)
{
s1[x]=y;
}
}
}
s=find(0);
count=0;
for(j=0;j<n;j++)
{
if(s==find(j)) //找和0連起來(lái)的數(shù)字
{
count++;
}
}
printf("%d\n",count);
}
}