source
Description
The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit.
One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.)
As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'.
Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#').
You may assume that the maze exit is always reachable from the start point.
Output
For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.
Sample Input
2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########
Sample Output
37 5 5
17 17 9
題意:分別求出左手摸墻算法和右手摸墻算法伴嗡,最短路徑所需要的步數(shù)急波。其中闹究,S為起點(diǎn)幔崖,E為終點(diǎn)。S赏寇,E不在墻角价认,S,E不相鄰渠退,但都位于四條邊上,而且一定存在一條路徑可達(dá)終點(diǎn)碎乃。
題解:摸墻算法是根據(jù)百度百科的流程圖寫出來的。而最短路徑還是用BFS惠奸。
左手摸墻流程圖

#include<cstdio>
#include<queue>
#include<iostream>
#include<string.h>
using namespace std;
int *up;
int *down;
int *lef;
int *rig;
int row,col;
int *temp;
char maze[50][50];
int vis[50][50];
int to[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
pair<int, int> src;
pair<int, int> tag;
int lSum;
void reset()//初始狀態(tài)
{
up[0]=-1;up[1]=0;
down[0]=1;down[1]=0;
lef[0]=0;lef[1]=-1;
rig[0]=0;rig[1]=1;
}
void rightRotate()//右旋
{
temp = up;up = rig;rig = temp;
temp = down;down = lef;lef = temp;
temp = lef;lef = rig;rig = temp;
}
void leftRotate()//左旋
{
temp = up;up = lef;lef = temp;
temp = down;down = rig;rig = temp;
temp = lef;lef = rig;rig = temp;
}
void leftHand()//左手摸墻
{
lSum = 0;
reset();
int x = src.first,y = src.second;
if (src.second == 0) rightRotate();//起點(diǎn)在左邊
else if (src.second == col - 1) leftRotate();//起點(diǎn)在右邊
else if (src.first == 0)//起點(diǎn)在上邊
{
rightRotate();rightRotate();
}
while (1)
{
if(maze[x][y] == 'E') break;
if(maze[x + lef[0]][y + lef[1]]!='#')
{
leftRotate();
if (maze[x + up[0]][y + up[1]] != '#')
{
x = x + up[0]; y = y + up[1];
lSum++;
}
}
else if (maze[x + up[0]][y + up[1]] != '#')
{
x = x + up[0];y = y + up[1];
lSum++;
}
else rightRotate();
}
printf("%d ", lSum+1);
}
void RightHand()
{
lSum = 0;
reset();
int x = src.first, y = src.second;
if (src.second == 0) rightRotate();
else if (src.second == col - 1) leftRotate();
else if (src.first == 0)
{
rightRotate();rightRotate();
}
while (1)
{
if(maze[x][y] == 'E') break;
if(maze[x + rig[0]][y + rig[1]]!='#')
{
rightRotate();
if (maze[x + up[0]][y + up[1]] != '#')
{
x = x + up[0];y = y + up[1];
lSum++;
}
}
else if (maze[x + up[0]][y + up[1]] != '#')
{
x = x + up[0];y = y + up[1];
lSum++;
}
else leftRotate();
}
printf("%d ", lSum+1);
}
struct Node{
int x,y,step;
};
int isBad(int r, int c)
{
if((r<0) || (r >= row) || (c<0) || (c >= col) ||(vis[r][c])||(maze[r][c]=='#')) return 1;
return 0;
}
void BFS()
{
lSum=0;
memset(vis,0,sizeof(vis));
vis[src.first][src.second]=1;
Node first;
first.x=src.first;
first.y=src.second;
first.step=0;
queue<Node> q;
q.push(first);
while(!q.empty())
{
Node curr=q.front(),next;
q.pop();
if((curr.x==tag.first)&&(curr.y==tag.second))
{
cout<<curr.step+1<<endl;
return;
}
for(int i=0;i<4;i++)
{
next=curr;
next.x=curr.x+to[i][0];
next.y=curr.y+to[i][1];
if(isBad(next.x,next.y)) continue;
vis[next.x][next.y]=1;
next.step=curr.step+1;
q.push(next);
}
}
}
int main()
{
int T;
scanf("%d", &T);
up = new int[2];
down = new int[2];
lef = new int[2];
rig = new int[2];
temp = new int[2];
while (T--)
{
scanf("%d%d", &col, &row);
for (int i = 0; i<row; i++)
{
scanf("%s",maze[i]);
}
for(int i=0;i<4;i++)
{
if(i==0) for(int j=0;j<col;j++){
if(maze[0][j]=='S'){
src.first=0;src.second=j;
}
else if(maze[0][j]=='E'){
tag.first=0;tag.second=j;
}
}
else if(i==1) for(int j=0;j<col;j++){
if(maze[row-1][j]=='S'){
src.first=row-1;src.second=j;
}
else if(maze[row-1][j]=='E'){
tag.first=row-1;tag.second=j;
}
}
else if(i==2) for(int j=0;j<row;j++){
if(maze[j][0]=='S'){
src.first=j;src.second=0;
}
else if(maze[j][0]=='E'){
tag.first=j;tag.second=0;
}
}
else for(int j=0;j<row;j++){
if(maze[j][col-1]=='S'){
src.first=j;src.second=col-1;
}
else if(maze[j][col-1]=='E'){
tag.first=j;tag.second=col-1;
}
}
}
leftHand();
RightHand();
BFS();
}
}