source
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1
1 2
0 2
0 0
Sample Output
Case 1: 2
Case 2: 1
題意:給出n個島伐脖,和雷達能覆蓋的最大半徑摔笤,島嶼分布在水平線以上风喇,雷達安裝在水平線上,求所需的最少的雷達數(shù)窄做。若存在雷達不能覆蓋所有島嶼的情況,輸出-1。
題解 :求出每個島嶼能夠被雷達覆蓋的雷達安裝區(qū)間,然后就等價于區(qū)間選點問題夺饲。
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
struct section{
double x,y;
} arr[1010];
bool cmp(const section & a,const section & b)
{
return (a.y<b.y)||((a.y==b.y)&&(a.x>b.x));
}
int main()
{
int n,cnt=1,flag;
double d,x0,y0;
while(scanf("%d%lf",&n,&d)&&(n||d)){
int sum=1;
flag=0;
for(int i=0;i<n;i++){
scanf("%lf%lf",&x0,&y0);
if(y0>d) {
flag=1;
continue;
}
double sqr=sqrt(d*d-y0*y0);
arr[i].x=x0-sqr;
arr[i].y=x0+sqr;
}
if(flag){
printf("Case %d: -1\n",cnt);
}
else
{
sort(arr,arr+n,cmp);
double dy=arr[0].y;
for(int i=1;i<n;i++)
{
if(arr[i].x>dy)
{
sum++;
dy=arr[i].y;
}
}
printf("Case %d: %d\n",cnt,sum);
}
cnt++;
}
}