題目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^?5?? ]), followed by N integer distances D?1?? D?2? ? D?N?? , where D?i?? is the distance between the i-th and the (i+1)-st exits, and D?N?? is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^?4?? ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^?7?? .
Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
注意點(diǎn)
一般這種短小精悍的題都會(huì)卡時(shí)限侠碧,因此不要大意缠黍,一開始就要朝著縮短時(shí)間的思路去。cin
cout
的耗時(shí)遠(yuǎn)遠(yuǎn)大于scanf
printf
替饿,因此如果有測試點(diǎn)通不過可以考慮改成scanf
printf
贸典,在數(shù)據(jù)量較大的情況下,可以節(jié)省至少10ms廊驼。
代碼
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
int n, m, sum = 0, a, b, ans = 0, temp;
scanf("%d", &n);
vector<int> dis(n + 1);
for (int i = 1; i <= n; i++) {
cin >> temp;
sum += temp;
dis[i] = sum;
}
scanf("%d", &m);
for (int i = 0; i < m; i++) {
scanf("%d %d", &a, &b);
if (a > b) swap(a, b);
temp = dis[b - 1] - dis[a - 1];
printf("%d\n", min(temp, sum - temp));
}
return 0;
}