傳送門
https://www.patest.cn/contests/pat-a-practise/1009
題目
This time, you are supposed to find A*B where A and B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
分析
1.因為只有兩個變量,所以沒用結(jié)構(gòu)體數(shù)組戈咳,用的pair代替变隔,以first為指數(shù)孤荣,second為系數(shù)。
2.遍歷兩個多項式赞警,每次獲得臨時的指數(shù)和系數(shù)逸吵,根據(jù)指數(shù)磷账,將系數(shù)加到對應(yīng)下標的數(shù)組里,每次記錄一下最大指數(shù)蒸辆,便于后面統(tǒng)計多項式的項數(shù)征炼。
3.最后格式化輸出結(jié)果即可。
源代碼
//C/C++實現(xiàn)
#include <iostream>
#include <vector>
using namespace std;
double res[2001]; //result polynomial
int main(){
int n;
scanf("%d", &n);
vector<pair<int, double>> v1(n); //the first polynomial
for(int i = 0; i < n; ++i){
scanf("%d %lf", &v1[i].first, &v1[i].second);
}
//input the second polynomial
scanf("%d", &n);
vector<pair<int, double>> v2(n); //the second polynomial
for(int i = 0; i < n; ++i){
scanf("%d %lf", &v2[i].first, &v2[i].second);
}
//compute
int tmp_exp;
double tmp_coef;
int max_exp = 0;
for(int i = 0; i < v1.size(); ++i){
for(int j = 0; j < v2.size(); ++j){
tmp_exp = v1[i].first + v2[j].first;
tmp_coef = v1[i].second * v2[j].second;
max_exp = (tmp_exp > max_exp) ? tmp_exp : max_exp;
res[tmp_exp] += tmp_coef;
}
}
//output
int count = 0;
for(int i = max_exp; i >= 0; --i){
if(res[i] != (double)0){
++count;
}
}
printf("%d", count);
for(int i = max_exp; i >= 0; --i){
if(res[i] != (double)0){
printf(" %d %.1f", i, res[i]);
}
}
}