PAT-1030-Travel Plan

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:
City1 City2 Distance Cost
where the numbers are all integers no more than 500, and are separated by a space.
Output Specification:
For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.
Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

#include <iostream>
#include <fstream>
#include <vector>
#define N 505
#define INF 0x7fffffff
#define min(x, y) x < y ? x : y

using namespace std;

struct Node{
    int no, dis, cos;
};

vector<Node> node[N];
int path[N];
bool mark[N];
int dist[N], cost[N];

void DFS(int dest)
{
    if(path[dest] == -1)
        return;

    DFS(path[dest]);
    cout << path[dest] << " ";
}

int main()
{
    ifstream cin("in.txt");

    int n, m, s, d;

    while(cin >> n >> m >> s >> d)
    {
        for(int i = 0; i < n; ++i)
        {
            node[i].clear();
            path[i] = -1;
            mark[i] = false;
            dist[i] = cost[i] = INF;
        }

        for(int i = 0; i < m; ++i)
        {
            int a, b, dis, cos;
            Node tmp;
            cin >> a >> b >> dis >> cos;

            tmp.no = b;
            tmp.dis = dis;
            tmp.cos = cos;

            node[a].push_back(tmp);
            tmp.no = a;
            node[b].push_back(tmp);
        }

        int newP = s;
        dist[newP] = 0;
        cost[newP] = 0;
        mark[newP] = true;
        
        for(int i = 1; i < n; ++i)
        {
            for(int j = 0; j < node[newP].size(); ++j)
            {
                int no = node[newP][j].no;
                int dis = node[newP][j].dis;
                int cos = node[newP][j].cos;

                if(mark[no] == true)
                    continue;

                if(dist[no] == INF || dist[no] > dist[newP] + dis || (dist[no] == dist[newP] + dis && cost[no] > cost[newP] + cos))
                {
                    dist[no] = dist[newP] + dis;
                    cost[no] = cost[newP] + cos;

                    path[no] = newP;
                }
            }
            int maxDis = INF;
            int maxCost = INF;

            for(int j = 0; j < n; ++j)
            {
                if(dist[j] == INF || mark[j] == true)
                    continue;

                if(dist[j] < maxDis || (dist[j] == maxDis && cost[j] < maxCost))
                {
                    maxDis = dist[j];
                    maxCost = cost[j];
                    newP = j;
                }
            }

            mark[newP] = true;
        }

        DFS(d);
        cout << d << " " << dist[d] << " " << cost[d];
    }

    return 0;
}
最后編輯于
?著作權(quán)歸作者所有,轉(zhuǎn)載或內(nèi)容合作請(qǐng)聯(lián)系作者
  • 序言:七十年代末膜廊,一起剝皮案震驚了整個(gè)濱河市袱结,隨后出現(xiàn)的幾起案子恢着,更是在濱河造成了極大的恐慌,老刑警劉巖危纫,帶你破解...
    沈念sama閱讀 212,718評(píng)論 6 492
  • 序言:濱河連續(xù)發(fā)生了三起死亡事件宗挥,死亡現(xiàn)場(chǎng)離奇詭異,居然都是意外死亡种蝶,警方通過(guò)查閱死者的電腦和手機(jī)契耿,發(fā)現(xiàn)死者居然都...
    沈念sama閱讀 90,683評(píng)論 3 385
  • 文/潘曉璐 我一進(jìn)店門,熙熙樓的掌柜王于貴愁眉苦臉地迎上來(lái)螃征,“玉大人宵喂,你說(shuō)我怎么就攤上這事』岚粒” “怎么了锅棕?”我有些...
    開封第一講書人閱讀 158,207評(píng)論 0 348
  • 文/不壞的土叔 我叫張陵,是天一觀的道長(zhǎng)淌山。 經(jīng)常有香客問(wèn)我裸燎,道長(zhǎng),這世上最難降的妖魔是什么泼疑? 我笑而不...
    開封第一講書人閱讀 56,755評(píng)論 1 284
  • 正文 為了忘掉前任德绿,我火速辦了婚禮,結(jié)果婚禮上退渗,老公的妹妹穿的比我還像新娘移稳。我一直安慰自己,他們只是感情好会油,可當(dāng)我...
    茶點(diǎn)故事閱讀 65,862評(píng)論 6 386
  • 文/花漫 我一把揭開白布个粱。 她就那樣靜靜地躺著,像睡著了一般翻翩。 火紅的嫁衣襯著肌膚如雪都许。 梳的紋絲不亂的頭發(fā)上,一...
    開封第一講書人閱讀 50,050評(píng)論 1 291
  • 那天嫂冻,我揣著相機(jī)與錄音胶征,去河邊找鬼。 笑死桨仿,一個(gè)胖子當(dāng)著我的面吹牛睛低,可吹牛的內(nèi)容都是我干的。 我是一名探鬼主播,決...
    沈念sama閱讀 39,136評(píng)論 3 410
  • 文/蒼蘭香墨 我猛地睜開眼钱雷,長(zhǎng)吁一口氣:“原來(lái)是場(chǎng)噩夢(mèng)啊……” “哼莺戒!你這毒婦竟也來(lái)了?” 一聲冷哼從身側(cè)響起急波,我...
    開封第一講書人閱讀 37,882評(píng)論 0 268
  • 序言:老撾萬(wàn)榮一對(duì)情侶失蹤,失蹤者是張志新(化名)和其女友劉穎瘪校,沒想到半個(gè)月后澄暮,有當(dāng)?shù)厝嗽跇淞掷锇l(fā)現(xiàn)了一具尸體,經(jīng)...
    沈念sama閱讀 44,330評(píng)論 1 303
  • 正文 獨(dú)居荒郊野嶺守林人離奇死亡阱扬,尸身上長(zhǎng)有42處帶血的膿包…… 初始之章·張勛 以下內(nèi)容為張勛視角 年9月15日...
    茶點(diǎn)故事閱讀 36,651評(píng)論 2 327
  • 正文 我和宋清朗相戀三年泣懊,在試婚紗的時(shí)候發(fā)現(xiàn)自己被綠了。 大學(xué)時(shí)的朋友給我發(fā)了我未婚夫和他白月光在一起吃飯的照片麻惶。...
    茶點(diǎn)故事閱讀 38,789評(píng)論 1 341
  • 序言:一個(gè)原本活蹦亂跳的男人離奇死亡馍刮,死狀恐怖,靈堂內(nèi)的尸體忽然破棺而出窃蹋,到底是詐尸還是另有隱情卡啰,我是刑警寧澤,帶...
    沈念sama閱讀 34,477評(píng)論 4 333
  • 正文 年R本政府宣布警没,位于F島的核電站匈辱,受9級(jí)特大地震影響,放射性物質(zhì)發(fā)生泄漏杀迹。R本人自食惡果不足惜亡脸,卻給世界環(huán)境...
    茶點(diǎn)故事閱讀 40,135評(píng)論 3 317
  • 文/蒙蒙 一、第九天 我趴在偏房一處隱蔽的房頂上張望树酪。 院中可真熱鬧浅碾,春花似錦、人聲如沸续语。這莊子的主人今日做“春日...
    開封第一講書人閱讀 30,864評(píng)論 0 21
  • 文/蒼蘭香墨 我抬頭看了看天上的太陽(yáng)疮茄。三九已至埂陆,卻和暖如春,著一層夾襖步出監(jiān)牢的瞬間娃豹,已是汗流浹背焚虱。 一陣腳步聲響...
    開封第一講書人閱讀 32,099評(píng)論 1 267
  • 我被黑心中介騙來(lái)泰國(guó)打工, 沒想到剛下飛機(jī)就差點(diǎn)兒被人妖公主榨干…… 1. 我叫王不留懂版,地道東北人鹃栽。 一個(gè)月前我還...
    沈念sama閱讀 46,598評(píng)論 2 362
  • 正文 我出身青樓,卻偏偏與公主長(zhǎng)得像,于是被迫代替她去往敵國(guó)和親民鼓。 傳聞我的和親對(duì)象是個(gè)殘疾皇子薇芝,可洞房花燭夜當(dāng)晚...
    茶點(diǎn)故事閱讀 43,697評(píng)論 2 351

推薦閱讀更多精彩內(nèi)容

  • 今日心享~享受自然 大自然,是天然的凈化器丰嘉,它完全在洗滌我的身體夯到! 我享受風(fēng),它可以輕微撫摸我的頭發(fā)饮亏; 我享受雨耍贾,...
    吸引力修煉閱讀 258評(píng)論 0 3
  • 這應(yīng)該是最近第二次被問(wèn)開不開心吧,說(shuō)實(shí)在被問(wèn)及時(shí)路幸,我有那么一絲尷尬荐开,不知道該怎么回答。我甚至百度了釋義:開心简肴,基本...
    自由和安閱讀 167評(píng)論 2 1
  • 另一個(gè)意思是晃听,事后可反思。 你還要好的朋友約著出去看電影砰识,但是到快要出去的時(shí)候能扒,有沒有見到他的人,給他電話也打不通...
    山人Shan閱讀 276評(píng)論 0 0
  • 1.逍遙嘆 愛已走到盡頭/恨也放棄承諾/命運(yùn)自認(rèn)幽默/想法太多/由不得我/壯志凌云幾分愁/知己難逢幾人留/再回首/...
    糾纏的離騷閱讀 581評(píng)論 16 10
  • 佛說(shuō)五百次回眸灵迫,換來(lái)今生的擦肩而過(guò)秦叛。 東北下雪了。整個(gè)白色的世界里我認(rèn)識(shí)了你瀑粥。你好挣跋,我叫馬克(這是真名,英文也一樣...
    Mark_ME閱讀 208評(píng)論 0 0