題目
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 1000≤1000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
題目大意
輸入一組數據(不一定遞增)嘉赎,讓你構造一個完全二叉搜索樹,且用層序輸出杜窄。
做法
- 將輸入的序列按遞增排好序
- 排好序的序列可以通過中序構造來構造完全二叉搜索樹颜及,同時利用好左兒子是根的2倍酝锅,右兒子是根的2倍+1,這個完全二叉樹的特點
代碼如下
#include <stdio.h>
#include <algorithm>
using namespace std;
const int Max = 1005;
int node[Max];
int tree[Max];
int pos,n;
void build(int root){
if(root > n)
return;
int left = root<<1;
int right = (root<<1)+1;
build(left);
tree[root] = node[pos++];
build(right);
}
int main(){
int i;
scanf("%d",&n);
for(i=0;i<n;i++){
scanf("%d",&(node[i]));
}
sort(node,node+n);
pos = 0;
build(1);
printf("%d",tree[1]);
for(i=2;i<=n;i++){
printf(" %d",tree[i]);
}
return 0;
}